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Crestron Fusion Cloud Add-In for 
Outlook Software 

Introduction 
The Crestron Fusion Cloud Add-In for Outlook (OLAI) adds the Crestron Fusion Cloud room 
booking wizard functionality to Microsoft® Outlook software when used with Crestron Fusion 
Cloud installed on-premises. This feature helps the user find available rooms and resources 
and sets actions and presets for meetings or appointments. This document is provided as 
an aid for installing the Outlook Web Service (OLWS) and Crestron Fusion Cloud Add-In for 
Outlook. 

For more information on how to use the Crestron Fusion Cloud Add-In for Outlook, refer to 
the Crestron Fusion Cloud Add-In for Outlook Software User Guide (Doc. 7895). 

NOTE:  The Crestron Fusion Cloud Add-In for Outlook is supported only on Crestron Fusion 
Cloud installed on-premises, and not on the Crestron® hosted service. 

Rights 
The rights to install the OLAI software depend on the company’s choice of operating 
systems and security policies. 

Version Compatibility 
Crestron Fusion Cloud supports Microsoft Outlook versions 2007, 2010, 2013, and Office 
365® software. Each new version of the OLWS and the OLAI supports all previous versions 
of the software. No compromise in existing functionality occurs. However, some new 
features might not be available if versions are mixed. To avoid any software issues, use the 
current version of the Crestron Fusion Cloud software. For additional information, contact 
the Crestron Fusion Support Group (FSG) at 1-888-273-7876 or e-mail fsg@crestron.com.  

Configuration Settings 
The configuration settings are held in a text file named OLAI.config. The configuration file 
contains the following settings: 

ServerPath: The ServerPath is the URL to the OLWS without the file name. 

Language: This is the language to be used in the OLAI User Interface (UI). 
  

mailto:fsg@crestron.com
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BookSingle: If the Book Single button is visible, then the value is true or false. BookSingle 
allows the user to quickly select a room for a meeting. The user can review the assets and 
custom fields for a particular room and bypass the room availability search. Microsoft 
Exchange declines the request if the room is busy. 

Installation 
The OLAI can be installed as a single instance on a PC or deployed to multiple PCs over a 
network using group policies. The OLWS needs to be installed before the OLAI on the  
on-premises Crestron Fusion Cloud server or in a place where the room, schedule, and 
asset services have access to the server. 

The installation is a two-part process as follows: 

1. Install the OLWS server-side software. 

Only one version of the OLWS is available. The OLWS installer is not specific to the 
32- or 64-bit versions of Outlook. The OLWS runtime automatically switches 
between 32- and 64-bit. 

2. Install the Crestron Fusion Cloud Add-In for Outlook client-side software. 

Depending on your version of Outlook, use the 32- or 64-bit installer, and then 
select an installation option (UI assisted or command line).  

•  The UI assisted installation is a desktop installation that uses the Previous 
and Next buttons to move through the installation. This method is not 
suited for production rollouts. Note that BookSingle is not available. 

•  The command line installation is typically used for automated distribution 
installations in large facilities. It includes switches to hide the User Interface 
(UI), server URL, and BookSingle activation. 

If you encounter any issues when installing the OLWS or OLAI software, contact FSG at  
1-888-273-7876 or email fsg@crestron.com.  

Outlook Add-In Web Service (Server-Side) Installation 
To install the OLWS, complete the following steps: 

1. For a client installation, right-click the cmd.exe shortcut, and then click Run as 
Administrator. 

In the Administrator: Command Prompt window, enter msiexec /i [MSI PATH] into 
the command line prompt. [MSI PATH] is the path to the msi file.  

Verify that the command is similar to the following:  
C:\Temp>msiexec /i c:\temp\OutlookWebServiceSetup_10_x_x.msi 

2. From the Welcome window, click Next to open the Select Installation Address 
window. 

3. Select Crestron Fusion Outlook Web Service from the Application Pool  
drop-down list. 

4. Click Next and then click Next again to open the Installing Crestron Fusion 
Outlook Web Service window. Please Wait should be displayed in the window. 

5. After the installation is complete, close the Setup panel. An IIS reset is not required. 

mailto:fsg@crestron.com


 

Installation Guide – DOC. 7894B Crestron Fusion Cloud Add-In for Outlook Software • 3 

6. To verify the URI address of the OLAI, open a web browser on a client or a staging 
computer.  

7. Enter the following command into the command line prompt:  
http://[server name]/fusion/outlookwebservice/addinservice.asmx. 

8. Press Enter. 

9. Verify that the page loaded displays AddinService in the heading. 

AddinService Window 

 

After completing the OLWS installation, install the OLAI. Depending on your version 
of Outlook, choose the applicable installation method: 

• Crestron Fusion Cloud Add-In for Outlook (UI Assisted 32- and -64-bit) 
installation 

• Crestron Fusion Cloud Add-In for Outlook (Command Line 32- and 64-bit) 
installation 

Instructions for these installation methods are described in the sections that follow. 

Crestron Fusion Cloud Add-In for Outlook (UI Assisted 32- and 64-Bit) 
Installation 
To install the OLAI, complete the following steps: 

1. Depending on your version of Outlook, use one of the following methods to verify 
that Outlook is 32- or 64-bit. 

• For Outlook 2007, click Help > About. The bit count is displayed. 

• For Outlook 2010 and 2013, click File > Help. The bit count is displayed 
under the About Microsoft Outlook section.  

2. To verify the URI address of the OLWS, open a web browser on a client or a 
staging computer.  

3. Enter the following command into the browser:  
http://[server name]/fusion/outlookwebservice/addinservice.asmx. 

4. Press Enter. 

5. Verify that the page loaded displays AddinService in the heading. 

AddinService Window 
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6. If your version of Outlook is 32-bit, right-click 
RVOutlookAddinSetup_x_x_x_32bit.exe. 

If your version of Outlook is 64-bit, right-click 
RVOutlookAddinSetup_x_x_x_64bit.exe. 

7. Click Run as Administrator to open the Welcome to the Crestron Fusion Add-In 
for Outlook Setup Wizard window. 

Welcome to the Crestron Fusion Add-in for Outlook Setup Wizard Window 

 

8. Click Next to open the Ready to Install window. 

Ready to Install Window 

 

9. Click Install to open the Installing window. 
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Installing Window 

 

After the setup process is complete, the Welcome to the Crestron Fusion Add-in 
for Outlook Setup Wizard window opens. 

Welcome to the Crestron Fusion Add-in for Outlook Setup Wizard Window 

 

10. Click Next to open the License Agreement window. 
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License Agreement Window 

11. Review the license agreement and then click I Agree.

12. Click Next to open the Outlook Web Service window.

Outlook Web Service Window 

13. Enter the Server Path (URL provided by Crestron) in the Web Service Folder field. 
Click Next to open the Select Installation Folder window.
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Select Installation Folder Window 

 

14. To install the OLAI into a folder other than the default folder, enter the desired 
location into the Folder field or click Browse to choose a location. 

15. Click Disk Cost to open the Crestron Fusion Add-in for Outlook Disk Space 
window.  

Crestron Fusion Add-In for Outlook Disk Space Window 

 

16. Choose a drive to install the OLAI, view the disk space information, and then  
click OK. 

17. Click Next from the Select Installation Folder window to open the Confirm 
Installation window. 
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Confirm Installation Window 

 

18. Click Next to confirm the installation and open the Installing Crestron Fusion  
Add-in for Outlook window. 

Installing Crestron Fusion Add-in for Outlook Window 

 

After the OLAI is installed, the Installation Complete window opens. 
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Installation Complete Window 

 

19. Click Close to open the Completing the Crestron Fusion Add-in for Outlook 
Setup Wizard window. 

Completing the Crestron Fusion Add-in for Outlook Setup Wizard Window 

 

20. Click Finish.  

21. To validate the installation, wait at least 5 minutes and then close and reopen 
Outlook. 
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22. Click Calendar and then click New Meeting to open a meeting. 

Calendar and New Meeting 

 

 

23. Click the Crestron RoomView® application button to load the Add-In services. 

Crestron RoomView 

 

When the Add-In services are loaded, a region list is displayed in the Room 
Selection window. 

NOTE: The Add-In services may take some time to load. 

Room Selection Window Displaying a Region List 
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Crestron Fusion Cloud Add-In for Outlook (Command Line 32- and  
64-Bit) Installation 
To install the OLAI, complete the following steps: 

1. Depending on your version of Outlook, use one of the following methods to verify 
that Outlook is either 32- or 64-bit. 

•  For Outlook 2007, click Help > About. The bit count is displayed. 

•  For Outlook 2010 and 2013, click File > Help. The bit count is displayed in 
the About Microsoft Outlook section.  

2. To verify the URI address of the OLWS, open a web browser on a client or staging 
computer. 

3. Enter the following address into the browser: 
http://[server name]/fusion/outlookwebservice/addinservice.asmx. 

4. Press Enter. 

5. Verify that the page loaded displays AddinService in the heading. 

AddinService Window 

 

6. Depending on the installation type, use one of the following methods to run the 
command line prompt as an administrator. 

•  For a client installation, right-click the cmd.exe shortcut and then click Run 
as Administrator. 

•  For an automated distribution, locate the prompt and enter the command 
in the distribution software. Verify that the account is run as an 
administrator. 

7. Enter [EXE path] /[URI Address] /verysilent into the command line prompt to install 
the OLAI.  

•  [EXE path] for 32-bit is RVOutlookAddinSetup_x_x_x_32bit.exe 

•  [EXE path] for 64-bit is RVOutlookAddinSetup_x_x_x_64bit.exe 

•  [URI Address] is url=http://[ServerName]/fusion/outlookwebservice 

Refer to the table below for information on switches. 

Switch Type Description 
/bsn This switch activates the BookSingle features and is either true or false. 

To enable the BookSingle functionality, add /bsn=true. For example, to 
add the /bsn switch type to the [EXE path] command above, enter 
RVOutlookAddinSetup.exe /bsn=true. 

/silent This switch runs setup automatically with the UI displayed. Input is 
inhibited. 

/url This switch sets the path to the Outlook web service. 

/verysilent This switch inhibits the UI and runs setup automatically. 
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8. Depending on the installation type, use one of the following methods to run the 
installation command. 

•  For a client installation, press Enter at the command prompt. 

•  For an automated installation, consult the manufacturer’s instructions on 
how to run the command. 

9. To validate the installation, wait at least 5 minutes and then close and reopen 
Outlook. 

10. Click Calendar and then click New Meeting to open a meeting.  

Calendar and New Meeting 

 

 

11. Click Crestron RoomView to load the Add-In services. 

Crestron RoomView 

 

 

When the Add-In services are loaded, a region list is displayed in the Room 
Selection window. 

NOTE: The Add-In services may take some time to load. 

Room Selection Window Displaying a Region List 
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